ab.com コミュニティ

ActiveBasicを通したコミュニケーション
現在時刻 - 2017年11月24日(金) 19:57

All times are UTC+09:00




新しいトピックを投稿する  トピックへ返信する  [ 4 件の記事 ] 
作成者 メッセージ
投稿記事Posted: 2006年3月29日(水) 11:28 
バグなのかどうかは不明なのですが、一応報告します。

職場のパソコン(XP/SP2)にActiveBasic(4.23)をインストールして使ってみたところ、デバックコンパイルで以下のようなコメントが出て止まりました。

  スレッド(&HB18)でアクセス違反がありました(EPI=&H7C809F64)。

デバックコンパイル/リリースコンパイルは正常に終了します。
リリースコンパイルのファイルも正常に動作します。
スレッドの値は毎回異なります。

個人で使用しているパソコン(XP)では正常に動作していますのでパソコンに依存する不具合かもしれませんが、職場のパソコンではVB.Net等は正常に動作しています。

対処方法など判りましたら、ご教授願います。


通報する
ページトップ
   
 記事の件名:
投稿記事Posted: 2006年3月29日(水) 14:10 
オフライン

登録日時: 2006年3月01日(水) 13:54
記事: 10
実は自分も似たようなの現象で悩んでいたのですが、下記のようにすればちゃんと動きました。

1.(必要であれば)新しい適当なアカウントを作成
2.いったんログオフ
3.別のアカウントにログイン
4.ユーザー切り替えで元のアカウントに再ログイン



要するに、ユーザーIDを0以外にすれば動作します。
ちなみに自分の環境ではGDB(gccのデバッガ)もユーザーIDが0だと動作せず、0以外にすると正常に動作します。

ただ管理者権限が必要なので、職場のパソコンでは、それはできないかもしれません。


通報する
ページトップ
 記事の件名:
投稿記事Posted: 2006年3月30日(木) 00:34 
そうなんですか・・・貴重な情報有難うございます。
やはり、パソコン(の環境)に依存する物だったのですね。

ご指摘のとおり、これだと私の職場のパソコンではデバックが出来ませんね。

作者様、なんとかならないでしょうか(泣)


通報する
ページトップ
   
 記事の件名:
投稿記事Posted: 2008年5月13日(火) 00:18 
同じ症状が出て困っています。
環境は、WinXPproSP2、ABver4.24です。

xsb7さんの方法で回避は出来てますが、面倒なのと少し気持ちが悪いです。
HiroCom777さんの投稿が2年前ですし、もしかしたら原因がわかるかもと思い質問します。

症状は全く同じで、デバックコンパイルで「スレッド(&HC90)でアクセス違反がありました(EPI=&H77D0F450)」が出てコンパイルが強制終了します。もちろん、デバックコンパイル/リリースコンパイルは正常に終了します。

気になる事は、
昨日までは正常でしたが今日から突然この症状になった。
RADで作ったWINDOWのシステムメニューの「X」で終了しようとすると必ず再現する。しかし、ボタンを配置しClickイベントで、以下を記述しボタンをClickすれば正常に終了します。

Sub MainWnd_CommandButton1_Click()
MainWnd_Destroy()
End Sub

以上の事で対処方法がわかる方はいれば教えてください。


通報する
ページトップ
   
期間内表示:  ソート  
新しいトピックを投稿する  トピックへ返信する  [ 4 件の記事 ] 

All times are UTC+09:00


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[2人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
cron
Powered by phpBB® Forum Software © phpBB Limited
Japanese translation principally by KONISHI Yohsuke